iCMS

Red Hat Linux 无法使用yum命令

iCMS http://www.hlike.cn 2018-08-08 10:48 出处:网络 编辑:@iCMS
好喜欢专业转载优质博客文章的地方哦~

一:首先提供部分Red Hat 镜像下载地址

1、rhel-server-6.8-i386-dvd.iso

链接:https://pan.baidu.com/s/18VqxRgBMuAJE7Ty0Hzle6g

密码:37e1

此镜像适用于32位win系统

2、rhel-server-6.9-XXX.iso

链接: https://pan.baidu.com/s/1QeC7Rn0_Umy4qJKbvx6HbA

密码: tgig

I386 是32位系统的,x86-64 是64位系统的

3、rhel-server-7.X-XXX.iso

链接: https://pan.baidu.com/s/1y52MAGNcjfC3tOMJEq8hjg

密码: vrg5

※ RHEL 7.0/7.1/7.2/7.3/7.4只有x86_64版本。所以只能安装到64位系统中,

个人建议学习是安装7.0即可

二、解决RHEL 无法使用yum命令的问题

1、为什么RHEL不能使用yum命令

因为它是收费的,所以系统需要先注册。

2、解决方案:使用centOS系统的yum库

2.1、清除原有RHEL的YUM及相关软件包.

rpm -qa | grep yum | xargs rpm -e --nodeps

2.2、查找与当前系统匹配的centOS系统版本

163的镜像库 (推荐

http://mirrors.163.com/centos/7/os/x86_64/Packages/

kernel镜像库

https://mirrors.edge.kernel.org/centos/7/os/x86_64/Packages/

2.3、下载RPM:

yum-3.4.3-158.el7.centos.noarch.rpm

yum-metadata-parser-1.1.4-10.el7.x86_64.rpm

yum-plugin-fastestmirror-1.1.31-45.el7.noarch.rpm

执行:

#rpm -ivh python-iniparse-0.3.1-2.1.el6.noarch.rpm

#rpm -ivh python-urlgrabber-3.9.1-11.el6.noarch.rpm

rpm -ivhyum-metadata-parser-1.1.4-10.el7.x86_64.rpm

rpm -ivhyum-plugin-fastestmirror-1.1.31-45.el7.noarch.rpmyum-3.4.3-158.el7.centos.noarch.rpm

*注释yum-plugin-fastestmirror和yum-3.4.3要一起安装。

2.4、cd /etc/yum.repos.d/

修改:redhat.repo 为redhat.repo.bak

下载CentOS-Base.repo 备注之前的repo文件

wget http://mirrors.aliyun.com/repo/Centos-7.repo

更改.repo文件

$basearch 为系统多少位的不用改

$releasever为对应的centos的版本号 本次例子就是7 把releasever全部替换为7

2.5、执行:

yum clean all

yum makecache

yum update

再试下yum命令是否成功了?

0

精彩评论

暂无评论...
验证码 换一张
取 消

热门标签